Why am I unable to launch MATLAB after upgrading to OS X 10.8 or later?

5 views (last 30 days)
After upgrading to OS X Mountain Lion, or OS X Mavericks, or OS X Yosemite, I am no longer able to start MATLAB. It either completely refuses to launch without any errors, or it shows the error "MATLAB cannot be opened because of a problem".

Accepted Answer

MathWorks Support Team
MathWorks Support Team on 11 May 2021
Edited: MathWorks Support Team on 12 May 2021
When MATLAB fails to start-up correctly following a major Operating System (OS) update, the issue is usually caused by a change to the OS's Windowing System or a change to your computer's MAC address configuration. Both of these issues have been known to pop-up following an update to OS X.
For MATLAB R2013b and higher, do not perform the steps below, contact MathWorks installation support instead.
For releases of MATLAB prior to R2012b, MATLAB used 'X11' as it's primary Windowing System, which has since been replaced by XQuartz.  As a result, whether you did an upgrade on top of your existing OS X or if you did a clean installation you will need to reinstall XQuartz for MATLAB R2012a and below. XQuartz can be downloaded from here:
If MATLAB isn't able to open after reinstalling XQuartz, the issue may be Java related. For MATLAB releases prior to R2013b MATLAB requires Apple's Java 6, which can be downloaded from here:
Once it is installed you should be able to launch MATLAB. However, if you are still having issues, please contact MathWorks installation support.
  1 Comment
Micah hamilton
Micah hamilton on 22 Jan 2014
I have the JDK 7 installed on my computer for development. I had to temporarily remove the java virtual machine from /library/java before the activation app could connect to Mathworks.

Sign in to comment.

More Answers (2)

Charles Flaum
Charles Flaum on 1 Jul 2015
To make Matlab 2010 or earlier run on Yosemite (10.10) or later you need the following steps:
1. Yosemite does not come with X11. You need to install it - use XQuartz 2.7.7. It is possible the XQuartz Installer will not install in the right folder. Make sure the X11 folder is in /opt (/opt/X11).
2. To enable help menus and doc browsers you need to install Matlab Java Patch.
Unfortunately, Mathworks released the patch tied to individual Matlab versions starting with 2101a. In order to install it with Matlab 2010a/b you need to copy the patch files in "patch" folder of the release into the Java folder of the contents of Matlab 2010a/b. Alternately, you can edit the script "main.scpt" inside the resources/scripts folder of the contents of the patch app, to replace all instances of the target version to the version you want to patch and then run the app.

Josue Lopez
Josue Lopez on 1 Oct 2015
I also had issues launching MATLAB R2013a off my computer after upgrading from Mountain Lion to Mavericks. I contacted the MathWorks Support Team and they tried to help. I really appreciate the time and advice they provided, but my issue is unfortunately still unresolved.
I followed all four procedures recommended by the help page on MATLAB Central "Why am I unable to launch MATLAB after upgrading to OS X Mountain Lion or OS X Mavericks?" but they still have not solved my issue.
First, I uninstalled XQuartz through two methods to make sure there was nothing on my system. I restarted my computer after steps 1 and 2.
1. Went to Utilities and trashed XQUartz 2. Followed the XQuartz wikipage and made the following commands via terminal:
launchctl unload /Library/LaunchAgents/org.macosforge.xquartz.startx.plist sudo launchctl unload /Library/LaunchDaemons/org.macosforge.xquartz.privileged_startx.plist sudo rm -rf /opt/X11* /Library/Launch*org.macosforge.xquartz.* /Applications/Utilities/XQuartz.app /etc/*paths.d/*XQuartz sudo pkgutil --forget org.macosforge.xquartz.pkg
Secondly, I uninstalled X11 by the next two steps. I restarted my computer after steps 1 and 2.
1. open /opt -> trashing x11 2. Entered the following commands in terminal:
sudo rm /usr/X11
Next I uninstalled MATLAB2013Ra, deactivated my license, and then reinstalled MATLAB2013Ra. When I double click on the Activate.app the application says that my license is active, so we now know that is not an issue.
Lastly, I performed the:
/Applications/MATLAB_<release>_Student.app/etc/maci64/lmutil lmhostid ifconfig


No tags entered yet.


Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!