MATLAB Answers

parpool fail with R2013b and new Mac Pro

2 views (last 30 days)
Joseph MacGregor
Joseph MacGregor on 11 Mar 2014
Commented: Walter Roberson on 25 Sep 2017
On a 6-core new Mac Pro (i.e., late 2013) running 10.9.2 and R2013b, parpool cannot successfully open a local pool of workers (e.g., parpool(4)). matlabpool does work, but only in a fresh MATLAB session and not if I have tried and failed to use parpool first. However, the parpool code I'm using does work on 4-core Windows 7 machines running R2013b.
Also, is this problem fixed in R2014a? I'm on a institutional license and R2014a has not yet propagated to my department.

  1 Comment

Edric Ellis
Edric Ellis on 12 Mar 2014
This is definitely not expected. I would suggest contacting MathWorks install support to resolve this.

Sign in to comment.

Answers (2)

Joseph MacGregor
Joseph MacGregor on 26 Mar 2014
Hmmm, now it works in R2013b and R2014a. Probably a reboot or two since I last tried this. I wonder if an earlier failed attempt at opening a pool poisoned the well for future attempts. I was new to parpool. False alarm, I guess.

  1 Comment

Edric Ellis
Edric Ellis on 26 Mar 2014
Strange. Glad it's working for you now.

Sign in to comment. on 25 Sep 2017
Uh, I have the same issue.

  1 Comment

Walter Roberson
Walter Roberson on 25 Sep 2017
Which MATLAB release are you using?

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!