Standolane application is not working like in app designer

21 views (last 30 days)
When packaging the app where is an in the app designer with a standalone application, I am taking this error. You can see this in the picture. Also, the packaged application is not working like an in the app designer. I mean, I put some buttons and a graph. The purpose is that you are clicking a button and then a graph is plotting. When I started in the app designer, there is no problem. Each button is working but when I packaged it, some buttons are not working. How can I solve this problem?
This graph is from App Designer
This graph is from Standalone Application
This is the error during packaging

Accepted Answer

Steven Lord
Steven Lord on 10 Jan 2022
That picture suggests there is an issue but it doesn't say anything about what that issue is. Can you review the log file linked in that dialog and show us the relevant section?
Since you're trying to create a standalone application from an App Designer app my guess is that you're running into the problems described in the "Fixing Callback Problems: Missing Functions" section on this documentation page and need to add in the pragma to ensure the missing function is included in the application.
As an example, if you're loading an object from a MAT-file and there's no indication in the code itself that the object's constructor needs to be included you may need to manually inform MATLAB Compiler to include that constructor file in the application.
  4 Comments

Sign in to comment.

More Answers (0)

Categories

Find more on Develop Apps Using App Designer in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!