Trainscg works in R2014b but not in R2015b and R2016a

1 view (last 30 days)
circuit_designer5172
circuit_designer5172 on 7 Jul 2016
I have been working on the MNIST digit recognition problem and was using "Trainscg" to train my networks. I can get around 90% and maybe 400 epochs in R2014b. When I came back from vacation my Matlab was updated to 2016a and the exact same code now gets 20% accuracy and meets the gradient target in 9 epochs. I unistalled the updates, but want to know WHY this happened so I can fix the problem. Thanks!

Answers (1)

Luigi Faustini
Luigi Faustini on 26 Jan 2018
Did they ever help you? I ran in to a similar issue where (Matlab2017) I was training a net with trainlm and getting excellent results, then I switched over to trainscg (because I had to -- I waned to use a GPU to speed things up) and the results were very poor, errors went from .003 (typical) to .9 I tried tweaking all of the parameters, with no improvements. It seems like either trainscg is just a crappy algorithm -- or it is broken.
  1 Comment
circuit_designer5172
circuit_designer5172 on 26 Jan 2018
I never heard back. Your experience is similar to mine. I moved off of Matlab to python/theano/TF for my ML work.

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!