MATLAB Answers

Error using xlsread (line 260)

47 views (last 30 days)
Adriano
Adriano on 8 May 2017
Commented: dpb on 9 May 2017
Hello! Today "xlsread" function give me this error:
Error using xlsread (line 260)
Undefined function 'Activate' for input arguments of type 'Interface.000208D8_0000_0000_C000_000000000046'.
I have used xlsread many times and now it doesn't work. I tried to use xlsread on many excel files but the problem persists. The code I execute is very simple:
filename2 = 'C:\one.xlsm';
[data,names] = xlsread(filename2,'tool');
What can I do? many thanks!

  3 Comments

dpb
dpb on 8 May 2017
Restart Matlab for starters...
Looks like a registration problem on internals, maybe.
>> which Activate
Activate is a built-in method % Interface.Microsoft_Excel_9.0_Object_Library._Workbook method
>>
What happens if you try above?
Guillaume
Guillaume on 8 May 2017
I doubt that restarting matlab would make a difference, but you never know...
Most likely, the problem is with Excel, which for some reason, returned a worksheet to matlab that is not really a worksheet. Has any change been made to Excel?
dpb
dpb on 8 May 2017
Indeed, but it's an easy thing to try...but you're right it's probably something to do w/ Excel
Guess it never hurts to ask about version and so...

Sign in to comment.

Accepted Answer

Santhana Raj
Santhana Raj on 9 May 2017
Edited: dpb on 9 May 2017

  1 Comment

dpb
dpb on 9 May 2017
There's a half-dozen or so different symptoms/fixes there...which one, specifically solved your issue might be worth noting.

Sign in to comment.

More Answers (0)

Tags

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!