Which ModelSim editions can I use for cosimulation with HDL Verifier?

27 views (last 30 days)
Which ModelSim or Questa editions can I use for cosimulation with HDL Verifier?
When using an unsupported ModelSim edition, I see an error similar to the following:
# ** Error: (vsim-FLI-3155) The FLI is not enabled in this version of ModelSim.

Accepted Answer

MathWorks Support Team
MathWorks Support Team on 10 Aug 2022
Edited: MathWorks Support Team on 11 Aug 2022
Cosimulation with HDL Verifier should work with any full ModelSim edition that has ModelSim Foreign Language Interface (FLI) enabled, such as:
  • Questa Core/Prime
  • ModelSim DE (Deluxe Edition)
  • ModelSim SE (Special Edition)
  • ModelSim PE (Personal Edition)
  • ModelSim PE Student Edition
HDL Verifier does not support free editions of ModelSim as they do not have FLI enabled, such as:
  • ModelSim XE (bundled with Xilinx Vivado)
  • ModelSim ME (bundled with Microsemi Libero)
  • ModelSim Lattice FPGA Edition (bundled with Lattice iCEcube2)
  • ModelSim-Intel FPGA/Starter Edition (bundled with Intel Quartus)
  • QuestaSim-Intel FPGA/Starter Edition (bundled with Intel Quartus)
Note that the above information is only applicable for Windows Installation. Cosimulation Support for 32-Bit based ModelSim Editions on Linux was discontinued in release R2012b, which means that certain versions such as ModelSim DE will not work on a Linux Installation of MATLAB. Please verify that a 64-Bit version of the ModelSim edition you have chosen is available before attempting cosimulation on Linux.
Please contact Siemens EDA (formerly Mentor Graphics) to receive up-to-date information about the FLI availability in their products: https://eda.sw.siemens.com/
The HDL Verifier online documentation lists the supported versions of ModelSim or QuestaSim at: https://www.mathworks.com/help/hdlverifier/gs/supported-eda-tools.html

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!