bizarre issue when running abaqus in parallel from an app exe created with matlab

3 views (last 30 days)
Hi,
I have a really weird problem that I hope someone can help with:
I have developed an interface with matlab app designer. This app modifies some abaqus models, submit simulations and collects results. Until two weeks ago it was working fine. Now suddenly the abaqus runs start crashing when using multiple CPUs.
Here are some additional points:
  • matlab creates a bat file to run models, for example:
cd C:\Users\...Abaqus\Simulations\AbaqusModel & ^
abaqus job=AbaqusModel input=AbaqusModel ask_delete=OFF cpus=2 interactive
  • then it runs this bat file with:
system([SbatchFileName ' &']);
  • when this bat is executed by the standalone exe created by matlab, the abaqus run fails after start right when it is trying to do the domain decomposition by using multiple CPUs
  • if number of CPUs is set to one, it works fine
  • if one just double-clicks on the bat file, then it runs fine even with multiple CPUs (hence nothing wrong with bat file or the model)
  • it even runs without issue when the bat is executed from the interface, but the interface needs to be started within the matlab app designer (i.e. not using the standalone exe)
Does anybody has any idea why this might be? I find it puzzling since there is nothing wrong with the model or the bat file. Also abaqus does not complain during pre-processing and starts the analysis. It fails only when trying to use multiple CPUs.
I was wondering if it could be due to some recent windows security update, maybe the system does not trust an exe accessing CPUs?
any help would be appreciated.
Best regards,
Murat

Answers (0)

Products


Release

R2021a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!