Matlab 2022b installer is unable to start on an OpenRC (non-Systemd Linux) system

8 views (last 30 days)
Dear all,
Installer of Matlab 2022b first claimed that it cannot open a window.
Following answers on the Mathworks site and installing a few "missing" libraries (by running
and installing the next missing one then re-running it) I quickly hit
error while loading shared libraries: cannot open shared object file: No such file or directory
I am stuck here as on my Gentoo box with OpenRC (rather than Systemd) as the init system I cannot simultaneously install systemd.
I would be greatful for helping me out. Thank you in advance,
Miles Malone
Miles Malone on 8 Nov 2022
A workaround on openrc or any other init systems where you've got elogind installed is to symlink to as they both provide the symbols MATLABWindow is looking for. So symlink /lib64/ to /path/to/matlabInstallFiles/bin/glnxa64/, and run install as per normal
Tamás Kárpáti
Tamás Kárpáti on 16 Nov 2022
Dear Miles, thanks for your suggestion. I have came across this one and found out that it is unnecessary, as only libdbus depends on libsystemd and thus only replaced first. Currently I'm also replacing and libjawt (plus
Let me update the current situation for those who are interested:
I'm still in contact with the supporting team and the install process was lately done via the "silent install" method. MATLAB itself is not yet running. I will update when obtain a working MATLAB. On the other hand, it does not seem to be an OpenRC issue anymore but the origin is still not clear.

Sign in to comment.

Accepted Answer

Tamás Kárpáti
Tamás Kárpáti on 3 Mar 2023
Dear all,
The issue has been solved today, thanks to the Mathworks support and the local Gamax Laboratory Solutions in Hungary. Along the time the issue looked more and more complicated but looking back it is quite straightforward to solve. To summarize the general workflow of installing MATLAB under Linux if a failure (and error messages) are hit:
1, Install software dependencies -as suggested by the error messages (in my case libselinux and nss-utils).
2, Add necessary features to installed dependencies (from errmsgs, too, in my case Vulkan support to qtgui, libsdl2 and mesa, experimental features to Harfbuzz and an up-to-date set of graphics card drivers -binary blobs in my case).
3, Replace libraries (*.so* files) of the MATLAB Installer by symlinks to system provided ones ( --> /usr/lib64/ and --> /usr/lib/gcc/x86_64-pc-linux-gnu/11.3.0/ ... the Systemd dependence is hidden in these implicitely; try to use ldd and objdump as above).
4, Perform the installation (if still fails, follow the "silent method" or "silent installation" -for me only this worked).
5, Replace MATLAB-installed libraries (*.so* files) by symlinks to system provided ones (in my case the above two plus --> /usr/lib64/ as outdated and --> /opt/openjdk-bin-17.0.3_p7/lib/
This way I got rid of every error messages.
In my case MATLAB still failed to start up normally, as I got a blank (white) unresponsive window waiting endlessly. It turned out that MATLAB tried to get a license file (license.lic) but could not. The SOLUTION was to DOWNLOAD it from the Mathworks site AND PROVIDE it through the -c command line option, like
$ matlab -c ~/license.lic
Now MATLAB has just started to work for me. Last few hours I already noticed some further minor library issues that I think will be possible to solve as in 3, but anyways, the aboves give a working solution for now.
Note that in this case the -c option is necessary for even the -nodesktop or -h run.
Thanks a lot for all who answered here and out there at Gamax and Mathworks!
The issue is now closed.

More Answers (0)


Find more on Standalone Applications in Help Center and File Exchange




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!