Clear Filters
Clear Filters

2022b Beta is suddenly unlaunchable on macOS M1

1 view (last 30 days)
cr on 27 Nov 2022
Edited: cr on 1 Dec 2022
Today my matlab window became unresponsive. Not sure exactly when, but I had data import window and a plot open while connected to an external display. After a while I disconnected the monitor and later found matlab 2022b apple silicon beta unresponsive. After force quitting I found Matlab unlaunchable. When I click on the icon in launchbar it kind of initiates launch process and quits in an instant. I tried rebooting, removing caches in Mathworks and com.mathworks folder, removing R2022b in application support folder in vain. Console shows the following two lines when I try to launch[1]: Coalition Cache Hit: app<> [984][1] ([893]): Service exited with abnormal code: 1
Any idea what's wrong and how to fix.
Anton Kogios
Anton Kogios on 1 Dec 2022
I'm having the exact same problem except R2022b beta opens, and not the normal R2022b. Both used to open fine until I updated R2022b to Update 2 from Update 1. I am able to get R2022b to run fine by opening '/Applications/', but I don't think is a good permanent solution. Does that work for you (for the beta)?
cr on 1 Dec 2022
Edited: cr on 1 Dec 2022
I don't have regular R2022b installed (I doubt if I would even if I had it due to performance issues running over Rosetta). My 22b-beta fumbled and nothing like removing caches/app support folders worked. I restored the app from timemachine and it started working again. This worked despite the .app folder being seemingly pristine.

Sign in to comment.

Answers (0)


Find more on Introduction to Installation and Licensing in Help Center and File Exchange




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!