MATLAB Answers

Problem running gpu code

19 views (last 30 days)
nick
nick on 26 Dec 2011
I am trying to run the paralleldemo_gpu_backslash, but i am getting this error:
Starting benchmarks with 8 different single-precision matrices of sizes
ranging from 1024-by-1024 to 158720-by-158720.
Creating a matrix of size 1024-by-1024.
Gigaflops on CPU: 39.848217
Error using gpuArray (line 28)
The CUDA driver was found, but it is too old. The CUDA driver on your system is version: 3.2. The required
CUDA version is: 4 or greater.
Error in paralleldemo_gpu_backslash/executeBenchmarks (line 108)
A = gpuArray(A);
Error in paralleldemo_gpu_backslash (line 117)
[cpu, gpu] = executeBenchmarks('single', sizeSingle);
I have installed cuda version 4 after matlab. If i open cmd and run nvcc --version gives release version 4. Also, the environmental variables are set.
Have you any idea;

  0 Comments

Sign in to comment.

Answers (1)

John Melonakos
John Melonakos on 2 Jan 2012
My guess is that your driver is still too old. The driver install is different than the CUDA toolkit install. Best place to get drivers is http://nvidia.com/drivers

  0 Comments

Sign in to comment.