MATLAB Answers

Bug in Copy FIgure clips out part of figure

76 views (last 30 days)
T A
T A on 22 Sep 2017
Answered: Peter Middleton on 17 Dec 2019
I've recently installed Matlab (R2017a on Windows 10 Home) on a new laptop and just noticed that the Copy Figure button results in only part of the figure being pasted. Specifically, the upper-left portion of the figure is preserved, but the rest is lost. I've not done any adjustments to the figure dimensions nor axes bounds, nor am I using any specialized plotting software, so this appears to be the default behavior. I've tested pasting into several MS Office products and MS Paint, all showing the same behavior. Below is a sample of what gets pasted into MS Paint for reference.
Manually resizing the figure axis bounds so that the axis is located in the upper-left section of the figure window (shown in the second plot below) results in the entire figure being copy-paste-able. This seems to imply the issue is related to Matlab's perception of the figure bounding box.
I noticed this link: https://www.mathworks.com/matlabcentral/answers/197305-possible-bug-in-copying-figures which alludes to a similar issue, though it was R2015a. Thanks in advance for any help.

  2 Comments

Steven Lord
Steven Lord on 22 Sep 2017
I don't see any attached pictures. Please try attaching it or including it in a comment again using either the Image button (the one with the green picture) or the Attach file button (the one with the paperclip.)
T A
T A on 22 Sep 2017
Post updated with the figure, also added some more info.

Sign in to comment.

Accepted Answer

T A
T A on 3 Oct 2017
The problem appears to be with Windows 10. The zoom level setting in Windows 10 affects how multiple applications perceive a visible window's extent. For instance, the same buggy behavior can be seen in MS Excel by following these steps:
1) Open Excel and create a new empty spreadsheet
2) File some rows and columns with any data
3) Select the filled cells
4) Select Copy->Copy as Picture... in the toolstrip
5) Select Picture Format and click OK
6) Paste

  1 Comment

Mahdi Torabi
Mahdi Torabi on 24 May 2019
so is there any way to solve this?

Sign in to comment.

More Answers (2)

George Mencoff
George Mencoff on 2 May 2018
I was having the same problem on windows 10. If you click "edit" and "copy options", and change the clipboard format to bitmap, it may fix your problem. This worked for me.

  1 Comment

Ernst Broberg Hansen
Ernst Broberg Hansen on 4 Sep 2019
Excellent!
Worked for me as well. Exatctly same problem. Weird, that the problem started today, but I've had Win10 and Matlab for several months...

Sign in to comment.


Peter Middleton
Peter Middleton on 17 Dec 2019
Yes - just had the same issue. Go to Win10 display settings and select the recommended zoom level (150% on my system) - now pastes ok.

  0 Comments

Sign in to comment.

Sign in to answer this question.

Products