Clear Filters
Clear Filters

Webcam and other Support packages are not working in MATLAB 2014b.

4 views (last 30 days)
I used webcam in Matlab 2014b to acquire images. But today when I used webcam in matlab script, it shows an error
_
Error using webcam (line 13) MATLAB Support Package for Webcams has not been installed. Open Support Package Installer to install the Webcam Support Package._
I already installed Webcam Support Package and its location is C:\MATLAB\SupportPackages\R2014b\usbwebcams.
To change my support directory I used matlabshared.supportpkg.getSupportPackageRoot but it shows error
Undefined variable "matlabshared" or class "matlabshared.supportpkg.getSupportPackageRoot".
When I tried to reinstall webcam support package, it shows error that already you have R2014b\usbwebcams first make empty that. I have many other support packages and so don't want to reinstall every package again. How should I solve this problem?
Thanks.

Accepted Answer

Walter Roberson
Walter Roberson on 17 Jan 2018
You appear to have a corrupted list of add-ons. In R2014b, the only way to fix that was to uninstall them all, delete the add-ons directory, and re-install the ones you wanted.
  3 Comments
Walter Roberson
Walter Roberson on 17 Jan 2018
Deleting them all is the official support case advice from Mathworks. If it is important to you that you do not uninstall and delete the folder, then you should open a support case with Mathworks. I do not know if they would consider this to be something that required a support contract or if they would consider this to be covered by "license and installation" matters.
You should go through the Add-on Explorer (or whatever it was named then) to uninstall them. Some of the add-ons (especially arduino) use folders in two different locations.
Once you have uninstalled whatever you can uninstall, delete C:\MATLAB\SupportPackages\R2014b and also delete anything in your Downloads\MATLAB* directory.
If you were not able to uninstall some package then you might also need to use pathtool to remove the path to the package from your MATLAB path.
cr
cr on 9 Nov 2020
I have the same issue with genicam drivers for usb3 cameras in R2017a. Even after installing them imaqhwinfo shows no installed adaptors. I uninstalled the package from add-on explorer and reinstalled multiple times, in vain. The same drivers work in R2018b on the same pc. They even work fine in R2017a on another PC with exact same configuration. Any ideas what more to try?

Sign in to comment.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!