Clear Filters
Clear Filters

Use java runtime on newer JVM

8 views (last 30 days)
Jeff Mandel
Jeff Mandel on 29 Oct 2019
I have a matlab executable that I run in a Tomcat servlet. My development machine is Ubuntu 16.04 with Oracle JDK 8.xx. I am using Matlab 2019b and the correspnding MCR. The servlet runs without issue. Now I'm moving the system to AWS, which requires me to configure a new Ubuntu image. I don't have any way to install Oracle JDK 8 (or 9) on this machine, as they are end-of life. The servlet seg faults in the jdk library, presumably because it was compiled in JDK 8. I have installed open-jdk-8 on the AWS image, but it seems like there should be a more elegant solution.

Answers (0)

Categories

Find more on Get Started with MATLAB Compiler SDK in Help Center and File Exchange

Products


Release

R2019b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!