Differential equation and problem with minmax

2 views (last 30 days)
Melda Harlova
Melda Harlova on 6 Jan 2020
Edited: Philippe Lebel on 6 Jan 2020
Hi everyone,
I have an error in that line:
net=newff(minmax(p),[3,1],{'tansig','purelin'},'trainlm')
And this error 'minmax' requires Deep Learning Toolbox.
Can someone help me? Thanks!
clear all
load zad2.mat
k=1; n=length(x);
for i=1:n
for j=1:n
z(i,j)=u(i,j);
p(1,k)=x(i);
p(2,k)=y(j);
t(k)=z(i,j);
k=k+1;
end
end
figure(1), mesh(x,y,z);
net=newff(minmax(p),[3,1],{'tansig','purelin'},'trainlm');
net.trainParam.epochs=100;
net=train(net,p,t);
for i=1:n
for j=1:n
y(i,j)=sim(net,[x(i);y(j)]);
end
end
figure(2),mesh(x1,x2,y)

Answers (1)

Philippe Lebel
Philippe Lebel on 6 Jan 2020
Edited: Philippe Lebel on 6 Jan 2020
This error message tells you that you don't have the required package installed in order to use the minmax() function.
Matlab comes with a lot of functions. But for some speciallized topics there are packages (or expensions) you can buy in order to enhance matlab's capabilities. Minmax() seems to be one of those specialized functions that are part of the Deep Learning toolbox package.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!