MATLAB Answers

parsim() with fast restart returns different results

9 views (last 30 days)
I am running multiple simulations using parsim() with fast restart to accelerate execution. However, I have noticed that using parsim() with fast restart produces different results compared to sim() and parsim() without fast restart. I have attached a simple model containing only SimEvents blocks and the code for running it. The model has a variable named InterGenerationTime, which is used by the Period field of the Entity Generator block. A SimulationInput object is used to set InterGenerationTime for different experiments. The To Workspace block records the number of entities generated by the block.
After running the code, the following figure is obtained.
The first two lines are just as expected, but the third line (parsim() with fast restart) is not. I assume there is something wrong with my implementation. Any help is appreciated.

  3 Comments

Rahul Kumar
Rahul Kumar on 15 Sep 2020
Looks like we get different results even in serial simulations. This might be an issue with Fast Restart and SimEvents and not parsim.
Reid Spence
Reid Spence on 15 Sep 2020
I concur with Rahul. If you change the sim() command to use fast restart you also get different behavior. The issue seems to be on the SimEvents side. If this issue is blocking you, please contact MathWorks Technical Support.
Example from my machine:
SimOutSim = sim(SimIn,'UseFastRestart', 'on');
Abdolkarim Mohammadi-Balani
Thanks Rahul and Reid. I informed MathWorks Technical Support about this.

Sign in to comment.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!