Clear Filters
Clear Filters

save matdata1 Error using save Unable to write file matdata1: permission denied.

3 views (last 30 days)
I cant save my file for some reason

Accepted Answer

Amit on 1 Feb 2014
This might be because you dont have permission to write in that folder. Try a different directory and see if it still doesn't work.
Aram Kirakosyan
Aram Kirakosyan on 23 Aug 2016
Ajay Joseph, may be you will be sooooo kind to answer to the question you posted......if you found it, just share it man

Sign in to comment.

More Answers (3)

Shivaputra Narke
Shivaputra Narke on 1 Feb 2014
Check the directory,because where you are writing your data on disk is important.

Marco Geraldo Vega Montenegro
Edited: Marco Geraldo Vega Montenegro on 27 May 2018
Tenía el mismo problema, lo resolví ejecutando Matlab como administrador. I had the same problem, i fixed it running Matlab as administrator.

Zadran on 25 Sep 2014
Hello Ajay Joseph. What way you found to fix the bug in your code. I too am facing the same problem in the code that I got from a friend but he too didn't know how to tackle it. I hope you may help.
How did you fix your own code and how you correlate that with the above.


Find more on Introduction to Installation and Licensing in Help Center and File Exchange


Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!