Cleaning parallel workers messages appears just immediately after running simulations when using parsim

2 views (last 30 days)
Rafael Borobio Castillo
Rafael Borobio Castillo on 9 Nov 2021
I am trying to run 100 parallel simulations using parsim. If I run 4 simulations (also in parallel), it runs perfectly. However, when I decided to run 100 simulations the parpool starts normally, but right after the "Running Simulations" message appears, it mentions that it is "Cleaning up parallel workers" as if it has already finished.
[09-Nov-2021 00:33:14] Checking for availability of parallel pool...
Starting parallel pool (parpool) using the 'local' profile ...
Connected to the parallel pool (number of workers: 4).
[09-Nov-2021 00:33:29] Starting Simulink on parallel workers...
[09-Nov-2021 00:33:34] Configuring simulation cache folder on parallel workers...
[09-Nov-2021 00:33:34] Loading model on parallel workers...
[09-Nov-2021 00:33:39] Running simulations...
[09-Nov-2021 00:35:12] Cleaning up parallel workers...
I had waited hours, and not even 1 simulation has conclude.

Answers (1)

Raymond Norris
Raymond Norris on 10 Nov 2021
I'm not a Simulink user, so bare with me in case I take you down the wrong path.
I'm guessing you are setting the parsim RunInBackground option to 'on', which will display the message. Take a look at
to see if it's required or if batchsim is a better option for your workflow.
  1 Comment
Rafael Borobio Castillo
Rafael Borobio Castillo on 12 Nov 2021
Thanks for the information. Apparently I was uploading too much data into the MATLAB workers and these cannot withstand it. I reduce it and it runs perfectly. However, batchsim might we a simpler way to upload data into a cluster and run my parallel simulations.
Have a pleasante day Raymond.
Rafael

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!