MATLAB Answers

Info

This question is closed.

Kalvin
0

I can't use Matlab 2013 R2013_Student on my Mac because of Yosemite!

Asked by Kalvin
on 17 Oct 2014
Latest activity Closed by John Kelly on 22 Oct 2014
Hello!
I recently downloaded OSX 10.10 on my mac (Yosemite) and I can no loger open MATLAB on my computer!
HELP ME!!!
THANK YOU!!!

  0 Comments

5 Answers

Answer by Marco
on 17 Oct 2014
Edited by Marco
on 18 Oct 2014
 Accepted Answer

Hey Kalvin,
I also use MATLAB R2013a (Student Version) and read a lot of reports about incompatibility of OS X Yosemite and MATLAB versions < R2014b. So my first try was an installation of Yosemite in Parallels Desktop as a virtual machine.
Within the VM these steps made MATLAB run:
  1. Install Java 6 for Mac: http://support.apple.com/kb/DL1572
  2. Install MATLAB
  3. Change the System Version in /System/Library/CoreServices/SystemVersion.plist. Search for the key ProductVersion and change the string from 10.10 to 10.90. You cannot edit this file directly, you have to copy it to your desktop, edit it and copy it back.
  4. Change the Bundle Version of MATLAB in /Applictions/Matlab_XXXX/Contents/Info.plist. Search for the key BundleVersion and change the string from 8.x.x to 9.x.x . To access it, you have to right click on MATLAB app in Applications and select Show Package Contents.
  5. You may have to start MATLAB manually by opening /Applictions/Matlab_XXXX/bin/matlab. (Currently I can open it directly after applying the changes above).
However these changes will break the disk utility and maybe have some additional (currently unknown) effects. So it would be a good idea the revert the changes described above when you quit MATLAB.
Please tell me if this workaround helped you, maybe I would then be convinced to upgrade my system, too. :-)
UPDATE
I found some reports, that the changes described above may cause your Mac to not start, therefore I wanted some automatism for this workaround. I found out, that the changes are only necessary until MATLAB is started, you can revert the changes directly afterwards.
So i wrote a little shell script which can be used to start MATLAB:
sudo sed -i '' 's/>10.10</>10.90</' /System/Library/CoreServices/SystemVersion.plist
open -a MATLAB_R2013a_Student
read -p "Press any key when MATLAB started..."
sudo sed -i '' 's/>10.90</>10.10</' /System/Library/CoreServices/SystemVersion.plist
Within execution of this script you are asked to enter your password and you need to confirm when MATLAB has successfully started.

  1 Comment

Works like a charm. Thanks you very much. I already managed to open up Matlab through the terminal, but I couldn't click the program icon. Now's it's working perfectly again.

Answer by Fernando
on 18 Oct 2014

Matlab released a patch for this: http://www.mathworks.com/support/bugreports/1098655

  1 Comment

That patch only works with R2013b and R2014a.

Answer by Max Moarle on 18 Oct 2014

I also have this problem: When clicking the Matlab icon, I obtain the message:
'You can’t use this version of the application “MATLAB_R2013a_Student” with this version of OS X. You have "MATLAT_R2013a_Student" R2013a (8.1.0).'
Anyone knows how to fix this?

  0 Comments


Answer by Marco
on 21 Oct 2014

MathWorks recently fixed it.
You have to install Java 6 manually from http://support.apple.com/kb/DL1572 and apply a Patch provided by MathWorks: http://www.mathworks.de/support/bugreports/1098655.

  1 Comment

is it also for student version? thanks.

Answer by Ramin
on 22 Oct 2014
Edited by Ramin
on 22 Oct 2014

There is an update for mac: R2008b - R2014a. Worked for me perfectly:

  0 Comments