Code generation information file does not exist.

817 views (last 30 days)
I have trying different example codes in simuling for android.
I am constantly getting the following error
" Code generation information file does not exist. "
What does the error mean?

Accepted Answer

Shaw on 25 Nov 2021
The issue was with path. The path was too long for the model to execute. I have shortened the path ,now the model works fine.
Dalia on 28 Aug 2023
i have shorten the path but still didn´t work

Sign in to comment.

More Answers (8)

Paniz Sedighi
Paniz Sedighi on 27 Nov 2022
I solved this problem by setting the workspace path to the same path as my Simulink file.
  1 Comment
Jesse Beaupre
Jesse Beaupre on 29 Mar 2023
It's a mystery to me why Simulink doesn't automatically set the correct path and you have to manually do it in 2023.

Sign in to comment.

Can Ahmet Dursun
Can Ahmet Dursun on 25 Jul 2023
For me it was the space character somewhere in the path.

Sutanu Maiti
Sutanu Maiti on 20 Nov 2021
Can you please try building corresponding example model once?
To launch the example model, please execute below commnd in MATLAB command window:
>> androidGettingStartedExample
  1 Comment
Shaw on 21 Nov 2021
I have tried for the above mentioned example.
The model executed with warnings.
But when I try to do with other examples, again the same error occurs.

Sign in to comment.

Abdelrahman Salah Elwakeel
I also faced the same problem. However, the fix for me was that I was using the wrong programming cable (some usb cables are just for power not for programming)
  1 Comment
Taimur Zaman
Taimur Zaman on 11 Apr 2023
Thats really strange. I am facing this problem in 2023 but my 2021 is not causing any problem

Sign in to comment.

Taimur Zaman
Taimur Zaman on 11 Apr 2023
I had this problem from long time. There is problem with matlab version 2022b and 2023 onwards. They dont set automatically the path which sometimes cuase this error. I opted to 2021 matlab, there you will have communication interface option to select SERIAL. I simply select this and now working. TI Launchpads the solution with problems :)
Taimur Zaman
Taimur Zaman on 11 Apr 2023
The path itself doesnt resolve it. You need to make sure your simulink file and workspace path is same. It can be accessed from the top ribbon of main window of matlab (command prompt area)

Sign in to comment.

abdullah on 25 Apr 2023
Ihave the same error in 2023 version when I use the s-function builder
have you solved it ?
  1 Comment
Dalia on 21 Aug 2023
Hello. How can you solve this, as I am getting the same problem?

Sign in to comment.

feng on 18 May 2023
In Model settings,choose Gnerate code only.

Go to the examples given in add ons - c2000 block set. There you will get the accurate solution.




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!