Bitstream generation problem in HDL coder

9 views (last 30 days)
KW YAN
KW YAN on 27 Jun 2022
Answered: KW YAN on 21 Jul 2022 at 9:23
Hi,
I am using HDL coder and trying to run a FIL test in my zedboard but encountering an issue that the bitstream is not showing up after everything in HDL coder run successfully, no critical warning or errors showing up.
If I use the HDL project generated by Matlab and run it in vivado for the bitstream generation, it is working and I can run the FIL test with that “manually generated” bitstream in Simulink.
So, the missing step now I have is the bitstream is missing at the end of HDL coder. Hope any of you could help to resolve this issue. Thanks a lot!
Note: the DUT I am trying to convert is only consisting a discrete time transfer function, nothing very complicated.
Best Regards,
Kelvin Yan

Accepted Answer

KW YAN
KW YAN on 21 Jul 2022 at 9:23
Hi all,
After spending quite some time in investigation and some support from Mathworks, it is figured out that the software "xterm" is needed on Linux for triggering the pop-up window, which will then compile the bitstream file. If anyone is suffereing such a problem, you might try to install this software on your machine. Hope this helps!
Best Regards,
Kelvin

More Answers (3)

Kiran Kintali
Kiran Kintali on 29 Jun 2022
Is it possible to attach a sample model?
Feel free to reach out to MathWorks technical support on this question.
  1 Comment
KW YAN
KW YAN on 5 Jul 2022
Hi Kiran,
I now upload the model for your reference, the DUT is the block called "controller" inside the Simulink model. You would need to run the "run_simple_model.m" script for initialization. Hope it helps! Thanks!
Best Regards,
Kelvin

Sign in to comment.


YP
YP on 29 Jun 2022
Edited: YP on 29 Jun 2022
At the last step in HDL Workflow Advisor, the FIL project will be synthesized, and then an external shell will pop up to continue with implementation and bit generation.
Do you notice the external shell?
  1 Comment
KW YAN
KW YAN on 5 Jul 2022
Hi YP,
No we dont see any pop-up at the end of the generation process.Very likely the part which runs the .tcl file is not started.
Best Regards,
Kelvin

Sign in to comment.


KW YAN
KW YAN on 29 Jun 2022
Hi Both,
Thanks for the response. I have already created a technical support request, I think you could see that in your system?
I would need some time to tidy up the model before I could upload it, maybe I would put it inside the technical request ticket.
However, I do locate the problem that should be because of the .tcl file for generating bitstream at the end was not running, also probably because of this reason, I didnt see a pop-up terminal at the last step of HDL Workflow Advisor.
If I would "manually" run that tcl script and use the generated bitstream and link it in the FIL block, then everything works fine. So, I guess it does not relates to my model but just with strange reason, that .tcl file was not running successfully.
Hope this could give you already some insights.
Best Regards,
Kelvin

Products


Release

R2022a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!