Simscape Results Explorer not showing entire simulation data

17 views (last 30 days)
I am running up to 20 minute simulations and am logging simscape data, but when I open the simscape results explorer, only the last second or so of data is shown. I have tried this with smaller simulation times down to 5 seconds with the same result; only the last ~1s is shown. I tried to change the 'limit time axis' option to 0, but there is just no data being logged as you can see in the image attached. After changing it to 0, I re-ran the 5 sec simulation, but it's the same result, it just auto selects the start time as the last second or so of any length simulation you have.
Any thoughts on why this is happening? This would be helpful for debugging.

Accepted Answer

J Chen
J Chen on 2 Aug 2022
Select Model Settings tab. Click Simscape. Uncheck "Limit data points" box.

More Answers (0)





Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!