Clear Filters
Clear Filters

Matlab doesn't open a .mlapp file created in a different computer

12 views (last 30 days)
Hi!
I have created a GUI using App Designer with Matlab version 2019a. It has a number of buttons, spinners, sliders and axes. Everything works well in the computer in which I created this GUI. However, if I copy this project to a different computer (also with Matlab version 2019a) I cannot access its code. I get the following error message when I try to open the .mlapp file:
Argument #1: image expected
This is annoying because I cannot modify the GUI from a different computer, only from the original one. Any ideas of what the problem could be?
If I run the GUI it works properly, it just doesn't allow me to edit it.
Thanks!
Jorge

Answers (2)

Allen
Allen on 11 Oct 2022
It appears that the application is looking for an image file, possibly assigned to a one or more of your app objects. I have found that when I create (Share), if all of the personal support files such as images are not in the same directory as the .mlapp file, it may not be automatically added to the list of included files.
Try recreating the .mlappinstall file and verify that all files being called within the app show in the list. If one or more missing there is an option to Add files/folders manually.

Image Analyst
Image Analyst on 11 Oct 2022
Edited: Image Analyst on 11 Oct 2022
If the .mlapp is on the other computer, and the other computer has MATLAB installed, you should be able to modify the app on the other computer. I do it all the time.
I agree with @Allen that it's probably some kind of path issue, like you're looking for an image that you forgot to ship with your app so the other computer doesn't have it, or it's located in a folder different than where it's looking.
Is this app on the other computer running the .mlapp file, or did you compile it into a standalone executable with the MATLAB Compiler product (in which case there is no source code on the other computer for you to modify)?
Can you attach your .mlapp file here with the paperclip icon so we can try it?
  7 Comments
Bruno Luong
Bruno Luong on 19 Jan 2023
Edited: Bruno Luong on 19 Jan 2023
I'm also able to open under R2022a without warning. Something is wrong with your PC (MATLAB installation ).
Jorge Barrasa
Jorge Barrasa on 19 Jan 2023
ok, turns out that the laptops that I´ve been trying with had all one thing in common. They all had an external library added to the path (specifically the DipImage library). Removing that library from the path solved the issue. I guess there must be some colission between function names of that library and the internal functions of the AppDesigner? who knows, anyways, problem solved ;)
Thanks @Bruno Luong for trying to help :)

Sign in to comment.

Categories

Find more on Introduction to Installation and Licensing in Help Center and File Exchange

Products


Release

R2019a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!