MATLAB Answers

JakeQ
0

Navigating supplemental software documentation freezes Matlab help browser.

Asked by JakeQ
on 17 Mar 2015
Latest activity Answered by Amandeep Singh on 8 Aug 2018
After upgrading from 2014b to 2015b the Matlab help browser has begun to hang (all Matlab windows hang as well) when I attempt to navigate to any page of my supplementary software documentation.
I have reviewed the 'Display Custom Documentation' docs and I don't see any indication that the info.xml or helptoc.xml need to be changed due to the upgrade (although I have updated the 'matlabrelease' tag of info.xml). I have deleted the old helpsearch-v2 directory and re-run the builddocsearchdb() function to generate helpsearch-v3.
From other threads I have read that executing
com.mathworks.mlwidgets.html.HtmlComponentFactory.setDefaultType('HTMLRENDERER');
could alleviate high cpu usage caused by JxBrowser. However, after trying that solution I have found that the link to view supplemental software no longer appears in the help browser which renders my documentation unreachable.
To be clear, the problem only seems to manifest when trying to browse away from the main page of my supplemental software documentation. Navigating the rest of the Matlab documentation does not cause any problems. Also, the software does not crash, or give error output. And, after several minutes, the help page will eventually load and other Matlab windows will become responsive. (Note however, that this problem occurs even if the supplemental software .html contains only text.)
Final note: Problem occurs with Matlab 2015a on Ubuntu GNOME 14.04 (64bit). Problem does not occur with Matlab 2015a on Windows 8.1 (64bit).

  0 Comments

Sign in to comment.

3 Answers

Answer by JakeQ
on 30 Mar 2015
 Accepted Answer

The following suggestion from Mathworks support solved this problem for me:
"Execute the following command at the beginning of a MATLAB session at the MATLAB command window:"
com.mathworks.mlwidgets.html.HtmlComponentFactory.setDefaultType('HTMLPANEL');
Apparently, my help browser was using jxbrowser 4, and the effect of this fix is to change it to use jxbrowser 3.

  1 Comment

Thank you so much, I already downgraded IE, restored windows before the problem appeard and even uninstalled matlab and reinstalled it. This is what fixed my problem.

Sign in to comment.


Answer by Wendy Fullam on 19 Mar 2015

Hi JakeQ, I recommend contacting our technical support team . They should be able to better assist you with troubleshooting this issue. If possible, they will want a copy of your supplemental software documentation, to help determine what is happening. Feel free to instead send me a direct message, if you prefer, and I will escalate the concern.

  1 Comment

Thank you for your answer. I have submitted this issue with the support team and so far they have been able to reproduce the problem. Assuming a solution exists, I intend to post their response as an answer here.

Sign in to comment.


Answer by Amandeep Singh on 8 Aug 2018

this solution is working . JUST TYPE THE BELOW LINE COMMAND WINDOW
com.mathworks.mlwidgets.html.HtmlComponentFactory.setDefaultType('HTMLPANEL');

  0 Comments

Sign in to comment.