MATLAB Answers

Simulink Project Cloned Repository not keeping configuration

1 view (last 30 days)
Dave Walter
Dave Walter on 20 Aug 2015
Answered: Dave Walter on 26 Sep 2016
I'm cloning a Simulink Project from git revision control. On my original workstation I have all the Model Configuration parameters set, such as simulation time, step time, discrete steps, etc. When I've cloned the repository onto a laptop and open the model, all the configuration parameters are default (10 seconds sim time, variable step solver, etc...
How do I get simulink project to push the configuration parameters to git?
Matlab 2014b

  0 Comments

Sign in to comment.

Accepted Answer

Dave Walter
Dave Walter on 26 Sep 2016
The issue is a compatibility issue between 2014b and 2015b. When the original Simulink Project was created and pushed to a remote repository using git and 2014b, if you clone that repo using 2015b it will not correctly clone the Configuration Parameters.

  0 Comments

Sign in to comment.

More Answers (1)

Tim Hosey
Tim Hosey on 26 Sep 2016
After committing your changes to your local repository, you must then push the latest commit in the local repository to the remote repository.
You can do this by clicking the push button in the source control panel in the bottom left hand corner of the Simulink Project's user interface.

  1 Comment

Dave Walter
Dave Walter on 26 Sep 2016
The repo has already been committed and pushed to a remote repository. The question is referring to after cloning the remote repository to a new computer.
I found the problem is a compatibility error from opening the Simulink Project in 2015b when it was cloned from a remote made from 2014b.

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!