MATLAB Answers

R2016a nouveau driver problems

9 views (last 30 days)
jamie mazer
jamie mazer on 31 Mar 2016
Commented: kul Meacheal on 15 Jun 2018
I just installed R2016a on top of a freshly installed linux LMDE2 distribution and ran into an old, but supposedly fixed problem with the open-source nouveau drivers. Essentially R2016a doesn't seem to properly support the standard linux video drivers.
Any idea what to do about this? I'd really like not to have to revert back to R2014a, the last version that worked out of the box on my lab computers. And installing the proprietary drivers is not an option for various reasons.
Doing: opengl('save', 'software') does seem to fix the problem, although I've been getting somewhat unpredictable renderings when rendering to a file using the print command (ie, print -png etc) that are difficult to reproduce..
Here's exactly what happens:
$ matlab
< M A T L A B (R) >
Copyright 1984-2016 The MathWorks, Inc.
R2016a ( 64-bit (glnxa64)
February 11, 2016
To get started, type one of these: helpwin, helpdesk, or demo.
For product information, visit
Academic License
>> plot(1:10);
>> libGL error: unable to load driver:
libGL error: driver pointer missing
libGL error: failed to load driver: nouveau
libGL error: unable to load driver:
libGL error: failed to load driver: swrast
com.jogamp.opengl.GLException: X11GLXDrawableFactory - Could not initialize shared resources for X11GraphicsDevice[type .x11, connection :0.0, unitID 0, handle 0x0, owner false, ResourceToolkitLock[obj 0x13b6cbb0, isOwner false, <45f699ec, 40f378d6>[count 0, qsz 0, owner <NULL>]]]
at jogamp.opengl.x11.glx.X11GLXDrawableFactory$SharedResourceImplementation.createSharedResource(
at Source)
Caused by: com.jogamp.opengl.GLException: AWT-EventQueue-0-SharedResourceRunner: Error making temp context(1) current: display 0x7fd57800c670, context 0x7fd578050ea0, drawable X11OnscreenGLXDrawable[Realized true,
Factory jogamp.opengl.x11.glx.X11GLXDrawableFactory@6927fd4,
Handle 0x5200002,
Surface WrappedSurface[ displayHandle 0x7fd57800c670
, surfaceHandle 0x5200002
, size 64x64
, X11GLXGraphicsConfiguration[X11GraphicsScreen[X11GraphicsDevice[type .x11, connection :0.0, unitID 0, handle 0x7fd57800c670, owner true, ResourceToolkitLock[obj 0x7c063aaa, isOwner true, <7cf5ae82, 659418e5>[count 2, qsz 0, owner <AWT-EventQueue-0-SharedResourceRunner>]]], idx 0], visualID 0x1f8, fbConfigID 0xec,
requested GLCaps[rgba 8/8/8/0, opaque, accum-rgba 0/0/0/0, dp/st/ms 16/0/0, dbl, mono , hw, GLProfile[GL2/GL2.sw], on-scr[.]],
chosen GLCaps[glx vid 0x1f8, fbc 0xec: rgba 8/8/8/0, opaque, accum-rgba 0/0/0/0, dp/st/ms 24/0/0, dbl, mono , hw, GLProfile[GL2/GL2.sw], on-scr[.]]]
, surfaceLock <5dee967c, 5ad9d711>[count 1, qsz 0, owner <AWT-EventQueue-0-SharedResourceRunner>]
, X11DummyUpstreamSurfaceHook[pixel 64x64]
, upstreamSurface false ]]
at jogamp.opengl.x11.glx.X11GLXContext.createImpl(
at jogamp.opengl.GLContextImpl.makeCurrentWithinLock(
at jogamp.opengl.GLContextImpl.makeCurrent(
at jogamp.opengl.GLContextImpl.makeCurrent(
at jogamp.opengl.x11.glx.X11GLXDrawableFactory$SharedResourceImplementation.createSharedResource(
... 2 more
MATLAB has experienced a low-level graphics error, and may not have drawn correctly.
Read about what you can do to prevent this issue by running this command: opengl problems,
then restart MATLAB.
To share details of this issue with MathWorks technical support, please
include this file with your service request: /auto/home/mazer/jogl.ex.9414
JavaSceneServerPeer problem: Couldn't create JOGL canvas--using painters
JavaSceneServerPeer problem: Couldn't create JOGL canvas--using painters

Answers (1)

Y on 10 Oct 2017
I meet the same problem, do u solve that?
kul Meacheal
kul Meacheal on 15 Jun 2018
my English is pool,but i met same problem,and i solved it the problem is because the opensl matlab do not fit the computer opensl you should create a soft link from computer to the MATLAB

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!