Sound Going Away After Using Matlab

3 views (last 30 days)
David Koenig
David Koenig on 8 Feb 2012
I have Qosmio X775 and Windows 7. I use the Matlab soundsc function a lot when I work on some waves sampled at 44KHz (hence big vectors and matrices).
I notice that if I work on Matlab for, say, an hour or so with the sound wave processing and then let the laptop sit for about an hour, when I come back the sound does not work. All of the indicators in the 'control panel/hardware and sounds' show that things are OK. Also, the speaker icon on the lower right hand side shows no problem. This seems to happen a couple of times a week. It did not happen on my old laptop which used XP.
I can solve the problem by rebooting.
Does anyone have a similar problem? If so, is there a way to recover without rebooting?
Thanks,
Dave

Accepted Answer

Jan
Jan on 9 Feb 2012
There are more sound problems with Matlab 2011b and Windows 7: I get a delay of 1.5 to 2 seconds after soundsc or audioplayer. In addition the Matlab session crashs, if an audioplayer object is deleted from a timer callback or if the object is stored persistently and Matlab is shut down.
I'm afraid these problems are solved by installing Matlab 2012a only.
  1 Comment
David Koenig
David Koenig on 9 Feb 2012
Thanks Jan. I noticed the soundsc problem with 2011b also and contacted Matlab who acknowledged the problem. I solved that one by going back to 2011a. Apparently, the dying sound problem that I mentioned in my original post is not shared by others...yet.

Sign in to comment.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!