Clear Filters
Clear Filters

Embedded Coder for TI C2000 not working as it was

8 views (last 30 days)
Dear friends,
I got a F28027 LaunchPad from a friend use in a project, and discovered the "Embedded Coder Support Package for Texas Instruments C2000 Processors" add-on that is able to program the LanchPad using the Simulink. I work with Simulink for a good time, so this was a good opportunity for a project.
After downloading, installing and doing the proper setup, I generated two CCS v6 projects in Simulink. Both of them could be imported by CCS v6 ("File" > "Import") and debug the board. When I was doing a 3rd project, I discovered that Simulink could build, load and run the code directly to the LaunchPad. It made my life easier. But, now, CCS v6 couldn't find the project to be imported. I noticed that there wasn't a "CCS_Project" folder in "Projectname_ert_rtw" folder generated by Simulink. But I didn't worried about it, since I was using the "build, load and run" configuration, thus didn't need CCS v6.
I really enjoyed it, so I bought a F28379D LaunchPad to be implemented in the final project. I created two Simulink files: "Test_CPU1" and "Test_CPU2". With simple blocks, I configured it the same as the F28037. When I build the project, again, CCS v6 couldn't import it, since there was the "CCS_Project" file. OK... not a big problem. But, this time, the "build, load and run" didn't worked. Even Simulink wasn't showing any error, the board just not worked.
I thought it was my fault on some configuration about Simulink for the dual core LaunchPad, and asked for help here in this forum yesterday. But today, I went back to the F28027. And this wasn't working either:
For the F28027, in the 3rd project (that was working with the "build, load and run" option), Simulink uploads the code into the LaunchPad. But the code seems that was never implemented. If I unplug the LaunchPad from the USB and plug it again, I runs a test-code from controlSUITE that was on it before I try to program with Simulink. And still no CCS v6 project.
For the F28027, in the 2 first projects (that generated a file to be imported by CCS v6), when I build the project to generate the file to CCS v6, now generates a file that can not be imported. An error pops up:
Error: Import failed for project 'Teste_1_F28027_Simulink' because its meta-data cannot be interpreted. Please contact support.
Well, basically, it was everything fine (except for the 3rd Simulink file wasn't generating a CCS v6 project) until I tried to program the F28379D. Now, nothing works, even keeping the same configurations in the previous files.
I re-installed the Embedded Coder Support Package for Texas Instruments C2000 Processors, but still the same thing. I re-installed CCS v6, but still the same thing.
I really don't know what is happening. Could someone help me?
-
Thank you very much,
Gabriel
-
Useful information:
MATLAB R2017a
Windows 10
CCS v6.2
Embedded Coder Support Package for Texas Instruments C2000 Processors v17.1.2 (with the C2000 v6.4.6 compiler)
controlSUITE v3.4.6
-
Edit: the command "xmakefilesetup" in the workspace results in an error:
Struct contents reference from a non-struct array object.
Error in xmakefile.Setup
Error in xmakefilesetup (line 11)
hObj = xmakefile.Setup;

Accepted Answer

Gabriel Pauka
Gabriel Pauka on 10 Aug 2017
Edited: Gabriel Pauka on 10 Aug 2017
Well, I don't know what that was, but it's fixed now. I uninstalled MATLAB, and installed again, but the problem persisted. Then, as a last resource, I performed a "clean uninstall" of MATLAB, as it was described on https://www.mathworks.com/matlabcentral/answers/131519-how-do-i-perform-a-clean-installation-of-matlab-on-a-windows-system#answer_138627 .
After re²installing MATLAB R2017a with the "clean uninstall", the Embedded Coder worked very well.
One thing that I noticed is that for small programs (using just a few and simple blocks), the coder does produce a CCS Project "importable" file. But for more complex builds (using several and complex blocks), it doesn't... but I'll try to figure it out later.
I'm posting this to leave a "solution" for anyone that suffers with this problem. So... that it is: a "clean uninstall" fixed it for me.
  1 Comment
Farya Golesorkhie
Farya Golesorkhie on 14 Aug 2018
Hi Gsbriel
I am having kind of the same problem. I am running a BLDC motor using f28027 and DRV8301. Simulink does not generate any error but the board does not work... Any suggestions is very much appreciated

Sign in to comment.

More Answers (0)

Products

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!