MATLAB Answers

C2000 Code Generation slow to compile

1 view (last 30 days)
Hi,
I'm using the Embedded Coder Support Package for Texas Instruments C2000 Processors add-on to load Simulink code into a TI Delfino (C28346).
It's been working great for weeks, but now, the "Deploy to Hardware" step gets stuck for about 15 minutes at this line in the Diagnostic Viewer:
### Using System Target File: C:\Program Files\MATLAB\R2017a\rtw\c\ert\ert.tlc
It's an intermittent problem, in that every now and then it will get through that step in a few seconds, but now most of the time it takes 15 minutes to compile. It never used to take that long to compile until recently. There's nothing out of the ordinary which has changed in our Simulink code.
Thanks! Matt

Accepted Answer

Antonin
Antonin on 29 Aug 2017
Hi Matt,
Any chance you could add your model for us to be able to reproduce the problem? You can contact tech support and send it to them if the material can't be shared openly.
Thanks,
Antonin.
  1 Comment
Matthew Granger
Matthew Granger on 19 Aug 2019
Looking back on this from two years ago, thought I would update this for any one else who has this problem.
I privately sent Antonin our code, and he pointed out that there was quite a bit of whitespace being added to my custom c code, which was slowing down the compiling process. Simply editing the code in, say, notepad++, and using the whitespace removal feature, sped the process up to normal speed.
Thanks again for the help!

Sign in to comment.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!