MATLAB Answers

MATLAB crashes on startup when using jvm (ubuntu 16.04.1)

10 views (last 30 days)
Michael Hennessey
Michael Hennessey on 16 Jun 2018
Commented: Pepijn Marcus on 25 Feb 2019
I recently installed MATLAB R2018a and experienced crashing on startup. Whenever I ran matlab from the terminal the splash would pop up for a few seconds, then the entire OS would freeze. I was forced to hard reset my computer as I was completely locked out. Because of this, no error messages or logs have been created at any point in time.
I then uninstalled MATLAB then reinstalled it and was met with the same error. I uninstalled MATLAB again then installed the R2016b version which works on another machine of mine with the same operating system. The exact same crashing recurred.
I then discovered that I am able to run MATLAB successfully if I start it with the -nojvm option. I then did a fresh install of java (OpenJDK version 1.8.0_171) after finding it was not installed. This did not resolve the issue.
Any help would be greatly appreciated, thank you.
  1 Comment
Gaston Melo
Gaston Melo on 20 Sep 2018
Did you solve your problem? Im expirience problems with ubuntu 18.04 and matlab 2018b. It only works with -nojvm. If I tried to launch matlab the system crash and need to reboot.Could this be a memory problem, i have 4 gb ram? i have installed oracle 8 -jre.

Sign in to comment.

Answers (3)


Gaston Melo
Gaston Melo on 22 Feb 2019
Hi, it depends on OS you have (linux version). In my case I was using Ubuntu and when matlab started the system crash due to CPU reach over 100%. So I needed to increase (i dont remember now the command) by console command. You can check the problem using the command "top" on linux console.
I changed Ubuntu to opensuse (tumbleweed) and matlab installation was really smooth (no problem at all).
Regards
Gaston
  1 Comment
Pepijn Marcus
Pepijn Marcus on 22 Feb 2019
Matlab indeed uses a lot of CPU when starting up, top showed up to 300% until crash. My PC has four cores, so I started with:
taskset -c 3 matlab
to try and boot matlab on all cores, to no avail. Will try to keep this updated while I try other things, if anyone can help I'd be much obliged.

Sign in to comment.


Gaston Melo
Gaston Melo on 22 Feb 2019
try this one
ulimit -c unlimited ./matlab
  1 Comment
Pepijn Marcus
Pepijn Marcus on 25 Feb 2019
That doesn't do anything, unfortunately (and neither does ulimit -c unlimited matlab).

Sign in to comment.

Products


Release

R2016b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!