Clear Filters
Clear Filters

Not responding on startup, macOS Mojave

91 views (last 30 days)
William Smith
William Smith on 17 Sep 2019
Commented: Artemis on 2 Feb 2024
I have just installed MATLAB 2019b on a Macbook Pro 2019 running macOS Mojave 10.14.6.
Just after installation, Matlab ran fine. However, if I now try to open it I see the splash screen then it freezes on the Matlab window showing no content and I have to force quit. If I run from the command line with -nodesktop it works and I can even load the desktop from there and it works ok. But if I try to load directly it hangs. I doubt it is a conflict as I have installed barely anything else on this macbook yet.
Athar Ali
Athar Ali on 28 Aug 2022
I experience same issue on MAC book Pro. Matlab 2020b and Matlab 2022a. While editing the figure or scope image.
Guillermo Aldana
Guillermo Aldana on 18 Dec 2023
Dissabling Grammarly did the trick for me - under privacy.

Sign in to comment.

Answers (24)

Jon Gotow
Jon Gotow on 29 Oct 2019
Edited: Jon Gotow on 21 Mar 2021
I'm the developer of Default Folder X. With the help of Philip Slaymaker I've tracked down the issue with Matlab. Matlab doesn't launch correctly if other apps use the Accessibility API (a part of macOS) to query it for information while it's launching.
A number of apps use the Accessibility API to communicate with other applications. These include Default Folder X, Magnet, Spectacle, and most other utilities that help you arrange / resize windows. If you run into this problem, you can narrow down the possible culprits by going to System Preferences > Security & Privacy > Privacy > Accessibility. This list shows all the applications that you've given permission to use the Accessibility API - one of them is triggering the bug in Matlab and causing it to hang. You'll need to use a process of elimination to determine which one, but it'll usually be an app that gets and sets information about other applications' windows.
Note that contacting the developer of any of these applications won't really help much, as it's not their fault. The fundamental issue is that Matlab contains a bug that causes it to hang when other apps request information via the Accessibility API. That bug needs to be fixed to resolve this problem. Phil Slaymaker submitted the bug to MathWorks - hopefully they'll fix it soon.
In the meantime, if you're a Default Folder X user, I have a version of DFX that may successfully work around the problem. I'd appreciate hearing from you at support (at) stclairsoft (dot) com.
- Jon
Jingjing Zou
Jingjing Zou on 19 Feb 2022
thank you for the answer. Unfortunately I still have the issue after checking and confirming no app is using the API. Matlab would initially start fine with slight lag. But after plotting a couple of figure, it freezes again and becomes unuseable.
Duncan Carlsmith
Duncan Carlsmith on 13 Apr 2023
Edited: Duncan Carlsmith on 13 Apr 2023
I found just now this advice fixed a number of issues, run 2023a MacBookPro M1 Ventura. Disabled Grammarian accessibility access and voila!! Thank you Jon.
P.S. After doing this, another issue disappeared - I found Image Viewer and Color Thresholder apps started working again. They would launch and then after loading a file become unresponsive.

Sign in to comment.

CoolNickname on 16 Mar 2020
Edited: CoolNickname on 24 Mar 2020
I had the same problem today with R2019b. Out of nowhere - well, after installing update 5 of R2019b - it stopped working. MATLAB would just not open after clicking it. The little dot under thy icon appeared and disappeared shortly after.
But I was able to start MATLAB through the terminal via
But the real problem solver was to give it full disk access. For that please go to Preferences > Security & Privacy > Privacy > Full Disk Access. There you should check MATLAB. Or, if it isn't listed, click on the + and look for it in the Application folder and add it to the list manually. After doing that it was good to go.
I also use the app "Magnet", but that didn't cause the problem. However, one should constrain Magnet to ignore MATLAB, otherweise MATLAB could be quite laggy.
Hope that helps.
Florian Anderl
Florian Anderl on 16 Aug 2023
Fixed it for me. Thank you very much.
Kwabena on 20 Oct 2023
Fixed it for me too. Thanks a lot

Sign in to comment.

Selene Schmittling
Selene Schmittling on 22 Apr 2020
Here I am again in this Discussion thread. I was so hoping I wouldn't have to return.
I run MATLAB R2019b on macOS Catalina 10.15.4. I have not had issues with MATLAB in a while then suddenly (when I'm under a time crunch, of course) I get the whiring pinwheel of death every time I open MATLAB.
What I am posting now is a quick and dirty way to get a responsive instance of MATLAB (I can't worry about an actual fix right now).
I open an instance of Terminal. I type "/{path_to_your_matlab_application_folder}/bin -nodesktop" (replace the material in braces {} with the path to your Matlab application folder).
This starts a command line instance of MATLAB (I assume). At the ">>" prompt I type "desktop".
Then I find myself in a working instance of MATLAB able to do my work.
You can find this solution by querying "MATLAB not responding". I may have cobbled it together by reading more than one post. I wanted to share here in the hopes that it kept others from unnecessary hair loss.
Parminder Basran
Parminder Basran on 23 Sep 2020
Edited: Parminder Basran on 23 Sep 2020
Thanks! This got me going again with my 2020a installation, mac 10.15.6
Anand Kulkarni
Anand Kulkarni on 31 Mar 2021
Thank you for posting this!! It works for me. 2020a with 10.14.6.

Sign in to comment.

Lin Qi
Lin Qi on 12 Aug 2020
Here is a solution maybe. Open MATLAB, and then open another app, or let another app come into the front, anyway let the MATLAB starting in the background. Then it would successfully startup every time on my laptop. If I just open MATLAB and let it starting in the front, it would be randomly a success or failure. Can't find any pattern.
goc3 on 5 Oct 2020
2020b does seem to have fixed the problem, as mentioned by @Lin Qi.
Also, having to put MATLAB in the background during startup does not seem to be required for 2020b.
Side note: none of the fixes mentioned in this thread, including letting MATLAB start up without focus, worked for me in 2020a, other than starting it up in terminal using the "-nodesktop" option and then running the desktop command.
Peter Kaczkowski
Peter Kaczkowski on 11 Dec 2020
Changing focus works for me too with 2019b. Unfortunately, the code I need to run does not yet work with 2020b, so I'm SOL.

Sign in to comment.

Gregor Dumphart
Gregor Dumphart on 11 Dec 2020
I was also troubled by Matlab R2020b getting stuck usually in the first minute of use on macOS Big Sur. I followed all suggestions in this topic, but to no avail.
Here's what fixed it for me: In System Preferences -> Accessibility -> Zoom, deactivate everything, especially Advanced -> Smooth Images. Immediately, my Matlab experience became a hundred times more fluent and I am stuck-free ever since.
Guo Jack
Guo Jack on 2 Dec 2021
Thank you so much. This also works for me.
Artemis on 2 Feb 2024
you genuinely fixed all my problems. I can't even begin to thank you. please have a great life

Sign in to comment.

Zongde Qiu
Zongde Qiu on 19 Sep 2019
same issue on MacOS 10.14.6

Selene Schmittling
Selene Schmittling on 23 Sep 2019
I have finally gotten MATLAB 2019b to work on my mac with os 10.14.6.
Initially, I could not even get MATLAB to run in Safe Boot Mode. However, after a clean uninstall (including deleting Mathworks folder out of "Application Support" folder, I was able to get it running.
There were four possible sources of conflict: Goolge Drive Stream, OneDrive, Spectacle and Echo Desktop auto-loader (loads when Echo pen connected to USB).
I turned all these off and opened MATLAB and it worked.
I turned off the automatic load of Echo Desktop and turned it back on. MATLAB still working
I also have a piece of software called Spectacle, which sizes windows with keystrokes. I turned that off and have since turned it back on and am still running MATLAB successfully.
I have not started up Google Drive Stream or OneDrive yet. I'm just so happy to have MATLAB working, I don't want to tempt fate. When I turn these back on, I'll post back my results.
I hope this helps someone else struggling with this issue too.
Regards and good luck,
Selene Schmittling
Selene Schmittling on 8 Oct 2019
I have reloaded Google File Drive Stream. It currently auto-loads on start-up and I have not had an issue yet with MATLAB 2019b.
This leaves One Drive, which was an issue for Viktor above. I'm loath to load it again and have my precious house of cards fall to its knees. For now, I'll keep it off.
However, if in the future I turn it back on and use MATLAB, I'll be sure to post my results.
Selene Schmittling
Selene Schmittling on 3 Nov 2019
AAAAAARRRRGGGHHHH!!!! This ridiculous bug is back (of course when I need to get some work done). I have this issue on a Mac Book Pro 2016 running Catalina 10.15.1.
MATLAB® people: please, please fix this.
I have been running MATLAB fine, even with Spectacle running, then out of the blue, MATLAB hangs again. Once it hangs, there is no way to get it running without reinstalling the whole mess again shy of (hopefully) booting in safe mode.
I went in and removed all items that required accessibility to whit: Spectacle, Duet and Google File Drive Stream. I have rebooted my machine (multiple times) and MATLAB still hangs.
This is beyond infuriating. I'm going to boot into safe mode and hope I can get my work done.

Sign in to comment.

Jason on 1 Dec 2019
I'm not sure if this is related, but when I upgraded to Catalina, I lost the ability to access many folders on my computer (Matlab R2017b). I added Matlab under System Preferences --> Security & Privacy --> Privacy --> Full Disk Access, but it didn't change anything. Upon bootup, Matlab can't find many of the files in the Matlab path. And I can't navigate to a lot of folders on the disk.
  1 Comment
Jason on 1 Dec 2019
I think I found the reason for the issue. Catalina moves any folders in the root directory of the computer into this folder: /Users/Shared/Relocated Items.
This effected some of my folders, so I will have to update everything in my Matlab path definition file unfortunately.

Sign in to comment.

Feiran li
Feiran li on 14 Feb 2020
Have the same problem Matlab2019b macOs Catalina 10.15.3. solved the problem by blocking Dropbox from System Preferences --> Security & Privacy --> Privacy --> Accessibility.
Ifeoma Nwogu
Ifeoma Nwogu on 16 Aug 2020
Actually, for me, blocking Dropbox wasn't enough, I had to remove it by clicking on the "-" sign on the Accessibility tab. I can always add it back using the "+" sign, but for now, I'm just glad to see my MATLAB up and workig again. I am using Matlab2019b as well.
George A.
George A. on 24 Nov 2020
Edited: George A. on 24 Nov 2020
I had to remove the app Contexts. Dropbox is ok for me.
With Contexts enabled I have to delete the folder "~/Library/Application\ Support/MathWorks/MATLAB/R2019b/" before opening Matlab.

Sign in to comment.

Guo Jack
Guo Jack on 6 Dec 2020
Edited: Walter Roberson on 20 Oct 2023
I tried above advices but it's still not working. I found another solution from
This is what I did:
1) Open terminal and type (you need to change the version in the following command line)
/Applications/ -nodesktop
2) Type “desktop” when matlab starts
3) Go to desktop matlab preference. Under "general", change the initial working folder to another one and it workded for me.
I benefit a lot seeking solutions for matlab issues and want to thank you all in this forum.
Hope it helps for y'all.

Brian Taylor
Brian Taylor on 7 Mar 2022
I have multiple screens and a laptop, Matlab refuses to go past the spash screen. I have discovered that by unplugging all of the extra screens that it will start. Would be nice to get this bug fixed.

Jonathan Lilly
Jonathan Lilly on 4 Oct 2019
A perhaps similar issue for me. Matlab 2019b was working, but there was a strange bug which is that I was unable to select text with the mouse in Matlab, which I do all the time. After reading this thread, I traced the problem to a window-sizing software called Magnet that I had recently installed. This solved the problem. Thanks!

Philip Slaymaker
Philip Slaymaker on 26 Oct 2019
I had a similar issue with Matlab 2019b (Matlab 2019a worked fine) not finishing initializing the command window and then freezing, requiring a force quit of Matlab. This happened on both Mojave 10.14.6 and High Sierra 10.13.6 on the iMac 27 2019 and 2017, respectively. I found that quitting and not running Default Folder 5.4.1 at all (or earlier versions) allowed Matlab to load and run. Rerunning Default Folder while Matlab was running caused Matlab windows to freeze.

Andriy Yabluchanskiy
Andriy Yabluchanskiy on 7 Nov 2019
Edited: Andriy Yabluchanskiy on 7 Nov 2019
i found that the problem, at least on my end, is somehow connected to the network in my institution. matlab runs fine when on my home network but always freezes on splash screen when at work
macOs Catalina 10.15.1
Matlab 2019b

robin tournemenne
robin tournemenne on 23 Jan 2020
I also have this problem. Among the list of possible conflicts with other softwares I see spectacle that I use basically always. Very annoying, please do something mathworks, now I need to work in the terminal witht he command matlab -nodesktop...

Selene Schmittling
Selene Schmittling on 23 Jan 2020
So, for the last few months, I have basically resorted to unloading Spectacle whenever I use MATLAB and not loading it again until I've close MATLAB.
This is extremely annoying but certainly less annoying than the unending spinning pinwheel of death.
Since using this procedure, I have not encountered any freezing issues. I have not checked whether OneDrive or Google File Stream continue to be issues. I will try to remember to do that and report back.

Yiqian Qian
Yiqian Qian on 24 Feb 2020
For my case, it conflicts with Google Drive Backup & when i quit Google Drive, it can be launched succesfully.

Mickey London
Mickey London on 28 Apr 2020
The feedback of disabling accessibility applications worked for me. The App the caused the issue was Magnets.
When checked out, Matlab stopped hanging.

Sangjae on 29 Jun 2020
Edited: Sangjae on 29 Jun 2020
I have same problem, MATLAB 2020a & MacOS Catalina
Zoran Popovic
Zoran Popovic on 29 Jun 2020
Running Matlab R2020a and Default Folder X 5.4.6 on Catalina v10.15.5. No problems after following Jon Gotow's tip above -
Sangjae on 30 Jun 2020
Thanks!, I tried removing all items checked in the accessibility,
but, unfortunately, it doesn't work in my case.
when I checked the syslog (/var/log/system), it said[1] (com.mathworks.matlab.19992[1601]): Service exited with abnormal code: 1

Sign in to comment.

Stefan Baginski
Stefan Baginski on 15 Aug 2020
My solution to this and the only one which allowed me to start MATLAB again was to delete the ~/Library/Application Support/MathWorks/MATLAB/R2020a
Afterwards MATLAB started again but unfortunately your settings are gone. So I recommend to make a copy of the folder just in case. But so far I was not able to figure out which file is causing the issue.
Jayasubba Reddy Yarava
Jayasubba Reddy Yarava on 31 Aug 2020
Edited: Jayasubba Reddy Yarava on 31 Aug 2020
Thank you Stefan, your suggestion worked for me.
Also I found now another solution which worked for me and is just that after starting MATLAB I switch to another program like Finder and let MATLAB start in the background. This was also mentioned here:
Dave on 4 Sep 2020
Yes, this was mentioned above, and it works for me. Easy but not very satisfying.

Sign in to comment.

Toby Driscoll
Toby Driscoll on 2 Sep 2020
For me the key was adding MATLAB to System Prefs / Security & Privacy / Accessibility. I'm running DFX, Dropbox, Google Drive Stream, and Spectacle–did not have to change those.
(This is for release 2020a on Catalina.)
Stefan Baginski
Stefan Baginski on 3 Sep 2020
I did that actually before I've used the background start methodology without success,
Best, S.
Dave on 4 Sep 2020
Yes, this did not work for me either.

Sign in to comment.

Griffin Willis
Griffin Willis on 7 Sep 2020
This has been happening to me too, I've figured out a way around it by simply going into your documents and opening a matlab file from your folders to launch matlab that way.
  1 Comment
Jon Sporring
Jon Sporring on 13 Oct 2020
I just had this problem with R2020b (9.9.01467703) on macOS Catalina (10.15.7). It was solved by starting /Applications/ from a terminal (with full disk access) once. Now Matlab does not hang, when I start it from Finder. Good luck.

Sign in to comment.

Brett Tofel
Brett Tofel on 25 Oct 2020
Same on bug on 2020a for Mac Catalina as with 2020b above, and same fix, but I remember this dumb bug from like 2018? This should really get fixed!

ting on 18 Nov 2023
Most likely it is due to conflicts with other software, especially plugins such as keyboardholder. By opening the monitor and closing them one by one, you can usually identify the conflicting plugin.


Find more on Startup and Shutdown in Help Center and File Exchange





Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!