How to solve a problem during hardware setup 'Accelerometer data from Pixhawk'?

18 views (last 30 days)
I'm setting up the PX4 Autopilot support package with Pixhawk1.
I confirmed that building and uploading the firmware was successfully.
but I could not get accelerometer data after uploading the firmware such as below figure.
How can I solve it??
Additionally I've tried to run a model(px4demo_ADC) in external mode.
But I got similar errors related to connection with pixhawk.
Error occurred while executing External Mode MEX-file 'ext_comm':
Timed-out waiting for second connect response packet.
Component:Simulink | Category:Block diagram error
Unable to connect to the 'PX4 Pixhawk 1' target for 'px4demo_ADC'.
My environments are Windows 10 64bit, Matlab 2019a, Pixhawk1.

Answers (3)

Jung-Ho Moon
Jung-Ho Moon on 7 Feb 2020
I solved this problem.
  1. When you set up hardware configuration in simulink, you sould enter 'COM4' instead of '4'.
  2. SD Card set-up is mandatory not option.

mehmet enes avcu
mehmet enes avcu on 6 Feb 2020
Hi moon
I have problem like your problem
did you solve this problem

islam dib
islam dib on 27 Feb 2020
In the hardware setup chose My board in not listed here
before that, found your fum version: enter in the qGroundControl ,
the pixhawk serie is detected there, and the fum version also. You can found your fum version whene you try to upload the firmware using Qground... (you found something like this: fum_v2 or fmu_v3 ...)
after determenation your fmu_version enter in the hardware setup: setect "" My board in not listed here""
then in "select Cmake configuration" chose your one (in my case fmu_v2): (chose defaut version)
follow the rest steps...

Products


Release

R2019a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!