??? There is no block named 'SimPowerSystems/Extra Library/Control Blocks/Timer'.

5 views (last 30 days)
i have this error in command window when i try to add simulink block Timer from SimPowerSystems .
add_block('SimPowerSystems/Extra Library/Control Blocks/Timer',timername,'MakeNameUnique','on')
i tried to search the correct path of the block using "gcb" from library
also i tried load_system ('SimPowerSystems')
but the same error figure out .
any help please !!

Answers (1)

Monika Jaskolka
Monika Jaskolka on 4 Mar 2020
I don't have R2010a installed, but will try to help.
1) Please ensure you have the SimPowerSystems toolbox installed. You can check what toolboxes you have installed by using the ver command. It should show up on this list. If not, you need to install it. Note that if you are using a newer version of Matlab, this toolbox is now called Simscape Electrical.
2) The path of the library Timer block may be incorrect. In the R2010a documentation shown below, it seems that it is located in SimPowerSystems/Extras/Control Blocks.




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!