MATLAB Answers

Error using concatenationLayer Cannot define property 'Name'

3 views (last 30 days)
I am trying to define a concatenation layer in Matlab 2020a but I get the following error:
Error using concatenationLayer Cannot define property 'Name' in class 'concatenationLayer' because the property has already been defined in the superclass 'Layer'.
I get the same error even using the simple command from the help from matlab
concat = concatenationLayer(4,2,'Name','concat')
This is strange, because I have been using this command since version 2019a but now that I migrated to 2020a I get the error.
I hope anyone can help me to fix this issue.
Best regards,


Sign in to comment.

Accepted Answer

Harsha Priya Daggubati
Harsha Priya Daggubati on 30 Jul 2020
Edited: Harsha Priya Daggubati on 30 Jul 2020
Did you try using a new layer name other than 'concat', as the error mentions the name has already been used in a superclass.
I tried to work the same at my end, it works completely fine for me.
If the problem still persists, try using the following commands and retry your work.
rehash toolbox
rehash toolboxcache


Show 4 older comments
José Enrique Almanza Medina
I did not create another layer, it is just the first line I type after launching matlab.
Also, I tried the code that you gave me but unfortunately I got the same error.
I did a workaround by defining the network architecture in another computer with Matlab 2019a and saving it and then I just load it in the 2020a version, then I can train the network, but it would be useful to be able to define it in the computer with 2020a version.
Harsha Priya Daggubati
Harsha Priya Daggubati on 30 Jul 2020
Can you just give a try with this command:
which concatenationLayer
This will be the expected output for the above command:
'C:\Program Files\MATLAB\R2020a\toolbox\nnet\cnn\concatenationLayer.m'
José Enrique Almanza Medina
That command showed me that I had a function made by me with the exact same name in my MATLAB folders. I think this is an old attempt to create my own version of the layer. This is quite silly from my side, it got mixed between a lot of scripts.
I removed it and that fixed the issue. Thanks a lot for your assitance.
Best regards,
José Almanza

Sign in to comment.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!