Failed to Launch Gazebo Simulation Environment

45 views (last 30 days)
Van Chuong Nguyen
Van Chuong Nguyen on 1 Feb 2021
Commented: shengqi xu on 27 Feb 2021
Hi all,
I am following this post to perform co-simulation between Simulink and Gazebo
I am using Virtual Machine to launch Gazebo Simulation Environment
After I open a terminal in the VM, run the following commands to launch the Gazebo simulator.
cd /home/user/src/GazeboPlugin/export
export SVGA_VGPU10=0
gazebo ../world/multiSensorPluginTest.world --verbose
Then I got the following error:
Unable to parse model.config for model[http://gazebosim.org/models/bin_4_dropping_task
I checked this error in many website sources but still not figured out.
I'd highly appreciate if you can give me some insights to fix this issue.
Thank you so much!
  1 Comment
shengqi xu
shengqi xu on 27 Feb 2021
same question, and then i used "Gazebo subscribe block" to subscribe the topic that i published in gazebo(Ubuntu), the "block" can not get any topic from gazebo, although i could see all the topic in ubuntu "gz topic -l"

Sign in to comment.

Answers (1)

Gaurav Bhosale
Gaurav Bhosale on 2 Feb 2021
Edited: Gaurav Bhosale on 2 Feb 2021
Hi Van,
The shipped VM contains older Gazebo version and RAM is limited to 2GB.
Can you please try following two things,
1] Upgrade Gazebo version to latest ( mostly 9.16 )
sudo apt-get install gazebo=9.16
2] Change RAM to 4GB from VM settings.
Please let me know, if you still face same issue.
Thanks.
  3 Comments
Van Chuong Nguyen
Van Chuong Nguyen on 4 Feb 2021
Thanks Gaurav,
I just tried sudo apt-get install gazebo=9.16, but it shows
E: Unable to locate package gazebo
Do you know why? Thank you.

Sign in to comment.

Products


Release

R2020b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!