MATLAB Answers

0

Algebraic Loop in Simulink, missing datas

Asked by Matlab User on 30 Aug 2019
Latest activity Commented on by Jesús Zambrano on 6 Sep 2019
Hello
I have a system which is strongly non-linear and can only be calculated by a loop in Simulink. The system is implemented using two "Matlab function" blocks.
The individual blocks each provide a good function flow (see Figure 1).
If I now connect the blocks together and interrupt the algebraic loop with the help of a "unit delay", then every second value is missing (see figure 2).
a schematic simulink model is attached
How can I fix this?
Greeting
Tobias

  0 Comments

Sign in to comment.

Products


Release

R2019a

1 Answer

Answer by Jesús Zambrano on 30 Aug 2019
Edited by Jesús Zambrano on 30 Aug 2019

Hi,
I see you have tried to introduce delays. Since you say it can only be solved in a loop (so it is not possible to solve the loops manually), then try to check the inital guess. Here i copy what is highlighted in the documentation:
Create Initial Guesses Using the IC and Algebraic Constraint Blocks
Your model might contain loops for which the loop solver cannot converge without a good, initial guess for the algebraic states. You can specify an initial guess for the algebraic state variables, but use this technique only when you think the loop is legitimate.
There are two ways to specify an initial guess:
  • Place an IC block in the algebraic loop.
  • Specify an initial guess for a signal in an algebraic loop using an Algebraic Constraint block.
Hope it can help you!

  2 Comments

Hi
thank you for the answer.
The IC block was a super idee : )
Greetings
Great to hear it!
best,
Jesús

Sign in to comment.