MATLAB Answers

Gtk-Message: 10:32:31.466: Failed to load module "canberra-gtk-module"

1,322 views (last 30 days)
Xiao Wang
Xiao Wang on 17 Jul 2019
I installed matlab 2019a with update3 on ubuntu 16.04 64bit. When I run matlab, I got output: Gtk-Message: 10:32:31.466: Failed to load module "canberra-gtk-module".
How to sort this problem.
Thanks in advance.
Zachary LaFlair
Zachary LaFlair on 17 Nov 2020
For anyone still bashing their heads off the wall in 2020 on R2020b. I'm using Arch Linux on Gnome Xorg. Currently patched at Kernel 5.9.8. I installed from the MATLAB website and created a folder with user permissions in the default install folder. Then ran ./install.
Here's what i used.
I first had to install gtk-2 package from the official arch repos.
sudo pacman -S gtk-2 %it might have worked after this if i didn't mess with my java install so much trying to make it work
Next i had to rollback my java version...
java --version %I had absolutely blown away my java install at this point and grabbed many packages from AUR to no avail so i got the official repo package
sudo pacman -S jre8-openjdk % Installs java
sudo pacman -S jdk8-openjdk % Installs java
Finally set matlab to open with my known good/supported version
export MATLAB_JAVA=/usr/lib/jvm/java-8-openjdk/jre
matlab %%opens MATLAB window without issues or failures
% I can and did plot a polynomial just to make it work
% First plot polynomial code that shows up on google.
y_1 = @(x) -0.6729+4.8266*x-0.4855*x.^2+0.0312*x.^3
x_1 = 0:0.1:33.5;

Sign in to comment.

Answers (10)

Scott Minkin
Scott Minkin on 15 Dec 2019
Edited: Scott Minkin on 15 Dec 2019
I believe the canberra-gtk-module messages have no detrimental effect on MATLAB and can be ignored, but having said that...
To run MATLAB R2019a or R2019b on Ubuntu 16.04 LTS without the canberra-gtk-message:
You have three environmental variables that need to be set before running matlab
export GTK_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0
export GIO_EXTRA_MODULES=/usr/lib/x86_64-linux-gnu/gio/modules
OR you can run matlab in the bash shell by typing:
$ GTK_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0 LIBOVERLAY_SCROLLBAR=0 GIO_EXTRA_MODULES=/usr/lib/x86_64-linux-gnu/gio/modules /usr/local/MATLAB/R2019a/bin/matlab
To run R2019a on Ubuntu 18.04 LTS without the canberra-gtk-message:
You need to install libcanberra-gtk-module and libgconf-2-4
You don't need to set any environmental variables.
To run R2019b on Ubuntu 18.04 LTS without the canberra-gtk-message:
you need to install libcanberra-gtk-module
You have one environmental variable that needs to be set before running matlab:
export GTK_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0
OR you can run matlab in the bash shell by typing:
$ GTK_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0 /usr/local/MATLAB/R2019b/bin/matlab
Good luck.
Paul Galloux
Paul Galloux on 21 May 2021
We have this messages with matlab 2020a ubuntu 18.04 :
Gtk-Message: 12:35:22.680: Failed to load module "overlay-scrollbar"
Gtk-Message: 12:35:22.685: Failed to load module "canberra-gtk-module"
and the command lines :
GTK_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0 LIBOVERLAY_SCROLLBAR=0 /usr/local/bin/matlab
or :
LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0/modules:$LD_LIBRARY_PATH LIBOVERLAY_SCROLLBAR=0 /usr/local/bin/matlab
solve this for us.
precisions : overlay-scrollbar and libcanberra-gtk-module had been already installed before the messages (sudo apt install overlay-scrollbar overlay-scrollbar-gtk2 libcanberra-gtk-module)
many thanks for the tip

Sign in to comment.

Xiao Wang
Xiao Wang on 18 Jul 2019
I did: sudo apt-get install libcanberra-gtk-module libcanberra-gtk0. But the error message is still there.
Maximilian Nentwich
Maximilian Nentwich on 9 Sep 2021
export GTK_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0
for MATLAB R2021a Update 4 and Ubuntu 20.04
Thank you!

Sign in to comment.

Jan Studnicka
Jan Studnicka on 16 Oct 2019
See bug reports:
"On some Linux distributions, a message appears in the terminal window when starting MATLAB:
Gtk-Message: <timestamp>: Failed to load module "canberra-gtk-module"
Gtk-Message: <timestamp>: Failed to load module "pk-gtk-module"
This message is informational and has no effect on MATLAB."
Robert Eng
Robert Eng on 26 Nov 2020
I tried the work around suggested in the "bug report" from the above link. Did not fix the problem. I can use the matlab as is with the error but irritating to keep the terminal open and running otherwise Matlab closes

Sign in to comment.

Frederico Azevedo
Frederico Azevedo on 14 Dec 2019
I had the same error with my R2019b installation in ubuntu 19.10. After I installed the module with "sudo apt install libcanberra-gtk-module -y", if I call matlab from the command line with the cmd "LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0/modules:$LD_LIBRARY_PATH /usr/local/bin/matlab", the error message doesn't appear anymore.

Chen Wang
Chen Wang on 12 Oct 2019
Finally I solve this problem by change from 2019b to 2019a. The error message disappear. There must be something wrong with 2019b's Linux version.

LeChat on 16 Jan 2020
Edited: LeChat on 16 Jan 2020
It had the same message and then I followed @Scott Minkin recommandation and I still have a message, but a different one:
me@myPC:~$ matlab &
[1] 22115
me@myPC:~$ Gtk-Message: 17:29:07.572: Failed to load module "canberra-gtk-module"
[0116/172911.622390:INFO:context.cpp(159)] Using multi-threaded message loop for Linux
me@myPC:~$ export GTK_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0
[1]+ Done matlab
me@myPC:~$ matlab &
[1] 29896
me@myPC:~$ [0116/173302.576327:INFO:context.cpp(159)] Using multi-threaded message loop for Linux
I then tried this:
me@myPC:~$ sudo apt install libcanberra-gtk-module libcanberra-gtk3-module
Reading package lists... Done
Building dependency tree
Reading state information... Done
libcanberra-gtk3-module is already the newest version (0.30-7ubuntu1).
libcanberra-gtk-module is already the newest version (0.30-7ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 13 not upgraded.
me@myPC:~$ matlab &
[2] 7532
me@myPC:~$ [0116/173838.654136:INFO:context.cpp(159)] Using multi-threaded message loop for Linux
In both case Matlab 2019b is launched as expected but I am wondering if everything is ok because of the messages I keep having in the Terminal.
I am running Ubuntu 19.10. Thank you for your expertise.
Manuel Mercier
Manuel Mercier on 16 Apr 2020
GTK_PATH=/usr/lib/x86_64-linux-gnu/gtk-2.0 GTK_MODULES = matlab
launch Matlab, and display
Failed to load module "pk-gtk-module"
in the console

Sign in to comment.

Burcin Arici
Burcin Arici on 9 Apr 2020
I also get the same error message while running
Gtk-Message: 04:38:48.679: Failed to load module "canberra-gtk-module"
for Matlab R2020a on Ubuntu 19.10, it works slower than R2019b but untill now, during running the program, it does not give an another error.

Kehelwala Dewage Gayan Maduranga
Edited: Kehelwala Dewage Gayan Maduranga on 18 Nov 2020
I am installing matlab R2020b on Ubuntu 18.04 and having this error
Gtk-Message: 17:15:55.104: Failed to load module "canberra-gtk-module"

Sign in to comment.


Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!